Jump to content

Проблема з USB камерою (стартує тільки 1 раз після налаштування)


Recommended Posts

Доброго дня! Останнім часом в окті є таке. Втрачає з'єднання з usb портом. У мене така ж біда, ще не налаштував.

Link to post
Share on other sites

В наявності OPI zero 256 + Logitech c310. Образ брав тут https://github.com/ludiazv/octocitrico . після включення сервісу і налаштування octopi.txt та ребуту камера стартує і працює, але донаступного 

перезавантаження, після цього запустити вже не виходить. і при старті апельсинки 

[  OK  ] Stopped the OctoPi webcam …ith the user specified config.
[FAILED] Failed to start the OctoPi…ith the user specified config.
See 'systemctl status webcamd.service' for details.

Лог з октопринту прикріпив.

Завчасно дякую.
 

octoprint.log

 

29 минут назад, Cynic сказал:

Доброго дня! Останнім часом в окті є таке. Втрачає з'єднання з usb портом. У мене така ж біда, ще не налаштував.

root@citrico-opizero:~# lsusb
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 046d:081b Logitech, Inc. Webcam C310
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 

камера в юсб пристроях є, але діод на ній не горить і вона не транслює зображення

 

Link to post
Share on other sites

У мене Logitech c255, так і не зміг запустити, підключив распі камеру.

Link to post
Share on other sites
14 хвилин тому, Cynic сказав:

У мене Logitech c255, так і не зміг запустити, підключив распі камеру.

але моя C310 працює, правда тільки після першого ребуту, а далі не хоче і на сайті октопринта вона значиться як така що підтримується....

Link to post
Share on other sites
28 минут назад, neon4ik сказал:

В наявності OPI zero 256

Я починав з такого пристрою і теж довго грався поки налаштував відео. Користувався ось цим посиланням.

https://www.iot-experiments.com/orange-pi-zero-and-webcam-for-octoprint/

Link to post
Share on other sites
4 хвилини тому, KomAndr сказав:

Я починав з такого пристрою і теж довго грався поки налаштував відео. Користувався ось цим посиланням.

https://www.iot-experiments.com/orange-pi-zero-and-webcam-for-octoprint/

я бачив цей мануал пробував по ньому, деякі команди не працюють. через перехід на 3 пітон більшість інструцій не актуальні...

Link to post
Share on other sites

@neon4ik треба піднімати mjpg-streamer інакше на помаранчі не вийде. До речі на форумі є готові образи під помаранч октопринта і кліппера, можна спробувати.

 

Link to post
Share on other sites

зараз спробую

 

проблему вирішив

хоч я і правив octopi.txt , а саме camera="usb", всеодно вибиралась не та камера (післе першого ребуту)

camera_usb_options="-d /dev/video1 -r 1280x720 -f 10" (а саме -d /dev/videoX) - примусовий вибір камери допоміг

 

  • Thanks 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...